File osmo-bsc.spec of Package osmo-bsc (Revision 128)

Currently displaying revision 128 , Show latest

157
 
1
#
2
# spec file for package osmo-bsc
3
#
4
# Copyright (c) 2017, Martin Hauke <mardnh@gmx.de>
5
#
6
# All modifications and additions to the file contributed by third parties
7
# remain the property of their copyright owners, unless otherwise agreed
8
# upon. The license for this file, and modifications and additions to the
9
# file, is the same license as for the pristine package itself (unless the
10
# license for the pristine package is not an Open Source License, in which
11
# case the license is the MIT License). An "Open Source License" is a
12
# license that conforms to the Open Source Definition (Version 1.9)
13
# published by the Open Source Initiative.
14
15
## Disable LTO for now since it breaks compilation of the tests
16
## https://osmocom.org/issues/4113
17
%define _lto_cflags %{nil}
18
19
Name:           osmo-bsc
20
Requires: osmocom-master
21
Version: 1.10.0.139.ba6fd
22
Release:        0
23
Summary:        OsmoBSC: Osmocom's Base Station Controller for 2G CS mobile networks
24
License:        AGPL-3.0-or-later AND GPL-2.0-or-later
25
Group:          Hardware/Mobile
26
URL:            https://osmocom.org/projects/osmobsc
27
Source: osmo-bsc_1.10.0.139.ba6fd.tar.xz
28
Source1: rpmlintrc
29
BuildRequires:  automake >= 1.9
30
BuildRequires:  libtool >= 2
31
BuildRequires:  pkgconfig >= 0.20
32
%if 0%{?suse_version}
33
BuildRequires:  systemd-rpm-macros
34
%endif
35
BuildRequires:  pkgconfig(libcrypto) >= 0.9.5
36
BuildRequires:  pkgconfig(libosmo-mgcp-client) >= 1.11.0
37
BuildRequires:  pkgconfig(libosmo-netif) >= 1.3.0
38
BuildRequires:  pkgconfig(libosmo-sigtran) >= 1.7.0
39
BuildRequires:  pkgconfig(libosmoabis) >= 1.4.0
40
BuildRequires:  pkgconfig(libosmocore) >= 1.8.0
41
BuildRequires:  pkgconfig(libosmoctrl) >= 1.8.0
42
BuildRequires:  pkgconfig(libosmogb) >= 1.8.0
43
BuildRequires:  pkgconfig(libosmogsm) >= 1.8.0
44
BuildRequires:  pkgconfig(libosmovty) >= 1.8.0
45
BuildRequires:  pkgconfig(talloc)
46
%{?systemd_requires}
47
48
%description
49
OsmoBSC: Osmocom's Base Station Controller for 2G circuit-switched mobile networks.
50
51
%package abisip-find
52
Requires: osmocom-master
53
Summary:        CLI utility to find ip.access compatible BTS
54
License:        GPL-2.0-or-later
55
Group:          Productivity/Telephony/Utilities
56
57
%description abisip-find
58
Command line utility to find ip.access compatible BTS.
59
60
%package ipaccess-utils
61
Requires: osmocom-master
62
Summary:        Command line utilities for ip.access nanoBTS
63
License:        GPL-2.0-or-later
64
Group:          Productivity/Telephony/Utilities
65
66
%description ipaccess-utils
67
This package contains utilities that are specific for nanoBTS when being
68
used together with OpenBSC. It contains mainly two tools: ipaccess-config
69
and ipaccess-proxy.
70
71
%package bs11-utils
72
Requires: osmocom-master
73
Summary:        Command line utilities for Siemens BS-11 BTS
74
License:        GPL-2.0-or-later
75
Group:          Productivity/Telephony/Utilities
76
77
%description bs11-utils
78
There is a tool in this package for configuring the Siemens BS-11 BTS.
79
Additionally, it contains one tool for making use of an ISDN-card and the
80
public telephone network as frequency standard for the E1 line.
81
82
%package meas-utils
83
Requires: osmocom-master
84
Summary:        Command line utilities for OsmoBSC's measurement reports
85
License:        GPL-2.0-or-later
86
Group:          Productivity/Telephony/Utilities
87
88
%description meas-utils
89
This package contains utilities for handling OsmoBSC's measurement reports
90
 * meas_json to convert measurement feed into a JSON feed
91
92
%prep
93
%setup -n osmo-bsc -q
94
95
%build
96
echo "%{version}" >.tarball-version
97
autoreconf -fi
98
%configure \
99
  --docdir=%{_docdir}/%{name} \
100
  --with-systemdsystemunitdir=%{_unitdir}
101
make %{?_smp_mflags}
102
103
%install
104
%make_install
105
106
%if 0%{?suse_version}
107
%preun
108
%service_del_preun %{name}.service
109
110
%postun
111
%service_del_postun %{name}.service
112
113
%pre
114
%service_add_pre %{name}.service
115
116
%post
117
%service_add_post %{name}.service
118
%endif
119
120
%check
121
make %{?_smp_mflags} check || (find . -name testsuite.log -exec cat {} +)
122
123
%files
124
%license COPYING
125
%doc AUTHORS README.md
126
%{_bindir}/osmo-bsc
127
%dir %{_docdir}/%{name}/examples
128
%dir %{_docdir}/%{name}/examples/osmo-bsc
129
%{_docdir}/%{name}/examples/osmo-bsc/osmo-bsc.cfg
130
%{_docdir}/%{name}/examples/osmo-bsc/osmo-bsc_custom-sccp.cfg
131
%{_docdir}/%{name}/examples/osmo-bsc/osmo-bsc-4trx-fh.confmerge
132
%{_docdir}/%{name}/examples/osmo-bsc/osmo-bsc-4trx.cfg
133
%{_docdir}/%{name}/examples/osmo-bsc/osmo-bsc-minimal.cfg
134
%dir %{_docdir}/%{name}/examples/osmo-bsc/ericsson
135
%dir %{_docdir}/%{name}/examples/osmo-bsc/nokia
136
%dir %{_docdir}/%{name}/examples/osmo-bsc/siemens
137
%{_docdir}/%{name}/examples/osmo-bsc/*/osmo-bsc*.cfg
138
%dir %{_sysconfdir}/osmocom
139
%config(noreplace) %{_sysconfdir}/osmocom/osmo-bsc.cfg
140
%{_unitdir}/%{name}.service
141
142
%files abisip-find
143
%{_bindir}/abisip-find
144
145
%files ipaccess-utils
146
%{_bindir}/ipaccess-config
147
%{_bindir}/ipaccess-proxy
148
149
%files bs11-utils
150
%{_bindir}/bs11_config
151
%{_bindir}/isdnsync
152
153
%files meas-utils
154
%{_bindir}/meas_json
155
156
%changelog
157