File libsmpp34.spec of Package libsmpp34 (Revision 26)
Currently displaying revision 26 , Show latest
98
1
#
2
# spec file for package libsmpp34
3
#
4
# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
5
# Copyright (c) 2016, Martin Hauke <mardnh@gmx.de>
6
#
7
# All modifications and additions to the file contributed by third parties
8
# remain the property of their copyright owners, unless otherwise agreed
9
# upon. The license for this file, and modifications and additions to the
10
# file, is the same license as for the pristine package itself (unless the
11
# license for the pristine package is not an Open Source License, in which
12
# case the license is the MIT License). An "Open Source License" is a
13
# license that conforms to the Open Source Definition (Version 1.9)
14
# published by the Open Source Initiative.
15
16
%define sover 1
17
Name: libsmpp34
18
Requires: osmocom-nightly = 1.0.0.202207200002
19
Version: 1.14.1.202207200002
20
Release: 0
21
Summary: PDU SMPP packaging and unpackaging tool
22
License: GPL-2.0-or-later AND LGPL-2.1-or-later
23
Group: Development/Libraries/C and C++
24
URL: https://osmocom.org/projects/libsmpp34
25
Source: libsmpp34_1.14.1.202207200002.tar.xz
26
BuildRequires: autoconf >= 2.57
27
BuildRequires: libtool
28
BuildRequires: pkgconfig >= 0.20
29
BuildRequires: pkgconfig(libxml-2.0)
30
31
%description
32
The library provides the PDU handling of the SMPP-3.4 protocol.
33
34
%package -n libsmpp34-%{sover}
35
Requires: osmocom-nightly = 1.0.0.202207200002
36
Summary: SMPP-3.4 protocol library
37
License: LGPL-2.1-or-later
38
Group: System/Libraries
39
40
%description -n libsmpp34-%{sover}
41
This library provides the Protocol Data Unit (PDU) handling of the
42
SMPP-3.4 protocol. SMPP (Short Message Peer-to-Peer) is a protocol
43
providing a data communication interface for the transfer of short
44
message data between External Short Messaging Entities, Routing
45
Entitites and Message Centres.
46
47
%package -n libsmpp34-%{sover}-devel
48
Requires: osmocom-nightly = 1.0.0.202207200002
49
Summary: Development files for the SMPP-3.4 protocol library
50
License: GPL-2.0-or-later
51
Group: Development/Libraries/C and C++
52
Requires: libsmpp34-%{sover} = %{version}
53
54
%description -n libsmpp34-%{sover}-devel
55
The library provides the PDU handling of the SMPP-3.4 protocol.
56
57
This subpackage contains libraries and header files for developing
58
applications that want to make use of libsmpp34.
59
60
%prep
61
%setup -q
62
63
%build
64
# HACK: don't let rpmlint abort the build when it finds that a library depends
65
# on a package with a specific version. The path used here is listed in:
66
# https://build.opensuse.org/package/view_file/devel:openSUSE:Factory:rpmlint/rpmlint-mini/rpmlint-mini.config?expand=1
67
# Instead of writing to the SOURCES dir, we could upload osmocom-rpmlintrc as
68
# additional source for each package. But that's way more effort, not worth it.
69
echo "setBadness('shlib-fixed-dependency', 0)" \
70
> "%{_sourcedir}/osmocom-rpmlintrc"
71
72
echo "%{version}" >.tarball-version
73
autoreconf -fi
74
%configure --disable-static --includedir="%{_includedir}/%{name}"
75
make %{?_smp_mflags}
76
77
%install
78
%make_install
79
find %{buildroot} -type f -name "*.la" -delete -print
80
81
%check
82
make %{?_smp_mflags} check || (find . -name testsuite.log -exec cat {} +)
83
84
%post -n libsmpp34-%{sover} -p /sbin/ldconfig
85
%postun -n libsmpp34-%{sover} -p /sbin/ldconfig
86
87
%files -n libsmpp34-%{sover}
88
%{_libdir}/libsmpp34.so.%{sover}*
89
90
%files -n libsmpp34-%{sover}-devel
91
%license COPYING
92
%doc ChangeLog
93
%{_includedir}/%{name}/
94
%{_libdir}/libsmpp34.so
95
%{_libdir}/pkgconfig/*.pc
96
97
%changelog
98