File neocon.spec of Package neocon (Revision 35)
Currently displaying revision 35 , Show latest
59
1
#
2
# spec file for package neocon
3
#
4
# Copyright (c) 2022, Martin Hauke <mardnh@gmx.de>
5
#
6
# All modifications and additions to the file contributed by third parties
7
# remain the property of their copyright owners, unless otherwise agreed
8
# upon. The license for this file, and modifications and additions to the
9
# file, is the same license as for the pristine package itself (unless the
10
# license for the pristine package is not an Open Source License, in which
11
# case the license is the MIT License). An "Open Source License" is a
12
# license that conforms to the Open Source Definition (Version 1.9)
13
# published by the Open Source Initiative.
14
15
# Please submit bugfixes or comments via https://bugs.opensuse.org/
16
#
17
18
19
Name: neocon
20
Requires: osmocom-nightly = 1.0.0.202208010002
21
Version: 1.0.2.202208010002
22
Release: 0
23
Summary: Simple serial console utility with re-open-after-disconnect
24
License: GPL-2.0-or-later
25
URL: https://github.com/openmoko/neocon
26
#Git-Clone: https://github.com/openmoko/neocon.git
27
Source: neocon_1.0.2.202208010002.tar.xz
28
29
%description
30
"neocon" is a simple serial console utility that tries to open a
31
ttys that may exist on a system until one such open succeeds. It
32
then passes terminal input and output, until there is a read or
33
write failure on the tty, in which case it disconnects, and the
34
process restarts.
35
36
%prep
37
%setup -q
38
39
%build
40
# HACK: don't let rpmlint abort the build when it finds that a library depends
41
# on a package with a specific version. The path used here is listed in:
42
# https://build.opensuse.org/package/view_file/devel:openSUSE:Factory:rpmlint/rpmlint-mini/rpmlint-mini.config?expand=1
43
# Instead of writing to the SOURCES dir, we could upload osmocom-rpmlintrc as
44
# additional source for each package. But that's way more effort, not worth it.
45
echo "setBadness('shlib-fixed-dependency', 0)" \
46
> "%{_sourcedir}/osmocom-rpmlintrc"
47
48
%make_build
49
50
%install
51
%make_install DESTDIR=%{buildroot} PREFIX=%{_prefix}
52
53
%files
54
%license debian/copyright
55
%doc README
56
%{_bindir}/neocon
57
58
%changelog
59