File osmo-e1d.spec of Package osmo-e1d (Revision b4a81a0ad11e2f585663595378a3ddfc)

Currently displaying revision b4a81a0ad11e2f585663595378a3ddfc , Show latest

143
 
1
#
2
# spec file for package osmo-e1d
3
#
4
# Copyright (c) 2022 SUSE LLC
5
# Copyright (c) 2019-2021, Martin Hauke <mardnh@gmx.de>
6
#
7
# All modifications and additions to the file contributed by third parties
8
# remain the property of their copyright owners, unless otherwise agreed
9
# upon. The license for this file, and modifications and additions to the
10
# file, is the same license as for the pristine package itself (unless the
11
# license for the pristine package is not an Open Source License, in which
12
# case the license is the MIT License). An "Open Source License" is a
13
# license that conforms to the Open Source Definition (Version 1.9)
14
# published by the Open Source Initiative.
15
16
Name:           osmo-e1d
17
Requires: osmocom-nightly = 202312172026
18
Version: 0.6.0.2.eccf.202312172026
19
Release:        0
20
Summary:        Osmocom E1 Daemon
21
License:        GPL-2.0-or-later
22
Group:          Productivity/Telephony/Utilities
23
URL:            https://osmocom.org/projects/osmo-e1d/wiki/Wiki
24
Source: osmo-e1d_0.6.0.2.eccf.202312172026.tar.xz
25
Source1: rpmlintrc
26
BuildRequires:  automake >= 1.9
27
BuildRequires:  libtool >= 2
28
BuildRequires:  pkg-config >= 0.20
29
%if 0%{?suse_version}
30
BuildRequires:  systemd-rpm-macros
31
%endif
32
BuildRequires:  pkgconfig(libosmocore) >= 1.9.0
33
BuildRequires:  pkgconfig(libosmousb) >= 1.9.0
34
BuildRequires:  pkgconfig(libosmovty) >= 1.9.0
35
BuildRequires:  pkgconfig(talloc) >= 2.0.1
36
%{?systemd_requires}
37
38
%description
39
osmo-e1d is an E1 interface daemon that is part of the Osmocom E1
40
interface driver architecture. It was primarily written for the
41
ICE40_E1_USB_interface (ICE40 based E1 framer IP core developed by
42
tnt).
43
44
osmo-e1d acts as an interface between the hardware/firmware of the E1
45
interface on the bottom side, and applications wanting to use E1
46
timeslots on the top side.
47
48
%package -n libosmo-e1d1
49
Requires: osmocom-nightly = 202312172026
50
Summary:        Osmocom E1 daemon protocol library
51
License:        LGPL-3.0-or-later
52
Group:          System/Libraries
53
54
%description -n libosmo-e1d1
55
Osmocom E1 Daemon Protocol Library.
56
57
%package -n libosmo-octoi2
58
Requires: osmocom-nightly = 202312172026
59
Summary:        Library for the Osmocom Community TDMoIP network
60
License:        LGPL-3.0-or-later
61
Group:          System/Libraries
62
63
%description -n libosmo-octoi2
64
Library for the Osmocom Community TDMoIP network.
65
66
%package devel
67
Requires: osmocom-nightly = 202312172026
68
Summary:        Header files for the Osmocom E1 daemon protocol library
69
License:        LGPL-3.0-or-later
70
Group:          Development/Libraries/C and C++
71
Requires:       libosmo-e1d1 = %version-%release
72
Requires:       libosmo-octoi2 = %version-%release
73
Provides:       libosmo-e1d-devel = %version-%release
74
Obsoletes:      libosmo-e1d-devel < %version-%release
75
76
%description devel
77
This subpackage contains libraries and header files for developing
78
applications that want to make use of libosmo-e1d.
79
80
%prep
81
%setup -n osmo-e1d -q
82
83
%build
84
echo "%version" >.tarball-version
85
autoreconf -fiv
86
# bugzilla.opensuse.org/795968 for rationale
87
%configure --includedir="%_includedir/%name" --disable-static \
88
    --docdir="%_docdir/%name" \
89
    --with-systemdsystemunitdir="%_unitdir"
90
%make_build
91
92
%install
93
%make_install
94
find "%buildroot" -type f -name "*.la" -delete -print
95
96
%check
97
%make_build check || find . -name testsuite.log -exec cat {} +
98
99
%post   -n libosmo-e1d1 -p /sbin/ldconfig
100
%postun -n libosmo-e1d1 -p /sbin/ldconfig
101
%post   -n libosmo-octoi2 -p /sbin/ldconfig
102
%postun -n libosmo-octoi2 -p /sbin/ldconfig
103
104
%if 0%{?suse_version}
105
%preun
106
%service_del_preun %name.service
107
108
%postun
109
%service_del_postun %name.service
110
111
%pre
112
%service_add_pre %name.service
113
114
%post
115
%service_add_post %name.service
116
%endif
117
118
%files
119
%license COPYING COPYING.gpl2 COPYING.lgpl3
120
%doc README.md
121
%_bindir/osmo-e1d
122
%_bindir/osmo-e1d-pipe
123
%dir %_docdir/%name
124
%dir %_docdir/%name/examples
125
%_docdir/%name/examples/
126
%_unitdir/osmo-e1d.service
127
%dir %{_sysconfdir}/osmocom
128
%config(noreplace) %{_sysconfdir}/osmocom/osmo-e1d.cfg
129
130
%files -n libosmo-e1d1
131
%_libdir/libosmo-e1d.so.*
132
133
%files -n libosmo-octoi2
134
%_libdir/libosmo-octoi.so.*
135
136
%files devel
137
%_includedir/%name/
138
%_libdir/libosmo-e1d.so
139
%_libdir/libosmo-octoi.so
140
%_libdir/pkgconfig/*.pc
141
142
%changelog
143