File osmo-e1d.spec of Package osmo-e1d (Revision 165)
Currently displaying revision 165 , Show latest
142
1
#
2
# spec file for package osmo-e1d
3
#
4
# Copyright (c) 2022 SUSE LLC
5
# Copyright (c) 2019-2021, Martin Hauke <mardnh@gmx.de>
6
#
7
# All modifications and additions to the file contributed by third parties
8
# remain the property of their copyright owners, unless otherwise agreed
9
# upon. The license for this file, and modifications and additions to the
10
# file, is the same license as for the pristine package itself (unless the
11
# license for the pristine package is not an Open Source License, in which
12
# case the license is the MIT License). An "Open Source License" is a
13
# license that conforms to the Open Source Definition (Version 1.9)
14
# published by the Open Source Initiative.
15
16
Name: osmo-e1d
17
Requires: osmocom-nightly = 202212080008
18
Version: 0.4.0.21.4c81e.202212080008
19
Release: 0
20
Summary: Osmocom E1 Daemon
21
License: GPL-2.0-or-later
22
Group: Productivity/Telephony/Utilities
23
URL: https://osmocom.org/projects/osmo-e1d/wiki/Wiki
24
Source: osmo-e1d_0.4.0.21.4c81e.202212080008.tar.xz
25
Source1: rpmlintrc
26
BuildRequires: automake >= 1.9
27
BuildRequires: libtool >= 2
28
BuildRequires: pkg-config >= 0.20
29
%if 0%{?suse_version}
30
BuildRequires: systemd-rpm-macros
31
%endif
32
BuildRequires: pkgconfig(libosmocore) >= 1.7.0
33
BuildRequires: pkgconfig(libosmousb) >= 1.7.0
34
BuildRequires: pkgconfig(libosmovty) >= 1.7.0
35
BuildRequires: pkgconfig(talloc) >= 2.0.1
36
%{?systemd_requires}
37
38
%description
39
osmo-e1d is an E1 interface daemon that is part of the Osmocom E1
40
interface driver architecture. It was primarily written for the
41
ICE40_E1_USB_interface (ICE40 based E1 framer IP core developed by
42
tnt).
43
44
osmo-e1d acts as an interface between the hardware/firmware of the E1
45
interface on the bottom side, and applications wanting to use E1
46
timeslots on the top side.
47
48
%package -n libosmo-e1d1
49
Requires: osmocom-nightly = 202212080008
50
Summary: Osmocom E1 daemon protocol library
51
License: LGPL-3.0-or-later
52
Group: System/Libraries
53
54
%description -n libosmo-e1d1
55
Osmocom E1 Daemon Protocol Library.
56
57
%package -n libosmo-octoi0
58
Requires: osmocom-nightly = 202212080008
59
Summary: Library for the Osmocom Community TDMoIP network
60
License: LGPL-3.0-or-later
61
Group: System/Libraries
62
63
%description -n libosmo-octoi0
64
Library for the Osmocom Community TDMoIP network.
65
66
%package devel
67
Requires: osmocom-nightly = 202212080008
68
Summary: Header files for the Osmocom E1 daemon protocol library
69
License: LGPL-3.0-or-later
70
Group: Development/Libraries/C and C++
71
Requires: libosmo-e1d1 = %version-%release
72
Requires: libosmo-octoi0 = %version-%release
73
Provides: libosmo-e1d-devel = %version-%release
74
Obsoletes: libosmo-e1d-devel < %version-%release
75
76
%description devel
77
This subpackage contains libraries and header files for developing
78
applications that want to make use of libosmo-e1d.
79
80
%prep
81
%setup -n osmo-e1d -q
82
83
%build
84
echo "%version" >.tarball-version
85
autoreconf -fiv
86
# bugzilla.opensuse.org/795968 for rationale
87
%configure --includedir="%_includedir/%name" --disable-static \
88
--docdir="%_docdir/%name" \
89
--with-systemdsystemunitdir="%_unitdir"
90
%make_build
91
92
%install
93
%make_install
94
find "%buildroot" -type f -name "*.la" -delete -print
95
rm -Rf "%buildroot/%_sysconfdir/osmocom"
96
97
%check
98
%make_build check || find . -name testsuite.log -exec cat {} +
99
100
%post -n libosmo-e1d1 -p /sbin/ldconfig
101
%postun -n libosmo-e1d1 -p /sbin/ldconfig
102
%post -n libosmo-octoi0 -p /sbin/ldconfig
103
%postun -n libosmo-octoi0 -p /sbin/ldconfig
104
105
%if 0%{?suse_version}
106
%preun
107
%service_del_preun %name.service
108
109
%postun
110
%service_del_postun %name.service
111
112
%pre
113
%service_add_pre %name.service
114
115
%post
116
%service_add_post %name.service
117
%endif
118
119
%files
120
%license COPYING COPYING.gpl2 COPYING.lgpl3
121
%doc README.md
122
%_bindir/osmo-e1d
123
%_bindir/osmo-e1d-pipe
124
%dir %_docdir/%name
125
%dir %_docdir/%name/examples
126
%_docdir/%name/examples/
127
%_unitdir/osmo-e1d.service
128
129
%files -n libosmo-e1d1
130
%_libdir/libosmo-e1d.so.*
131
132
%files -n libosmo-octoi0
133
%_libdir/libosmo-octoi.so.*
134
135
%files devel
136
%_includedir/%name/
137
%_libdir/libosmo-e1d.so
138
%_libdir/libosmo-octoi.so
139
%_libdir/pkgconfig/*.pc
140
141
%changelog
142