File osmo-iuh.spec of Package osmo-iuh (Revision 39)

Currently displaying revision 39 , Show latest

198
 
1
#
2
# spec file for package osmo-iuh
3
#
4
# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
5
# Copyright (c) 2021 sysmocom - s.f.m.c GmbH
6
#
7
# All modifications and additions to the file contributed by third parties
8
# remain the property of their copyright owners, unless otherwise agreed
9
# upon. The license for this file, and modifications and additions to the
10
# file, is the same license as for the pristine package itself (unless the
11
# license for the pristine package is not an Open Source License, in which
12
# case the license is the MIT License). An "Open Source License" is a
13
# license that conforms to the Open Source Definition (Version 1.9)
14
# published by the Open Source Initiative.
15
16
Name:           osmo-iuh
17
Requires: osmocom-nightly = 1.0.0.202208020002
18
Version:  1.3.0.202208020002
19
Release:        0
20
Summary:        Osmocom code for the Iuh interface (HNBAP, RUA, RANAP)
21
License:        AGPL-3.0-or-later AND GPL-2.0-or-later
22
Group:          Hardware/Mobile
23
URL:            https://osmocom.org/projects/osmohnbgw
24
Source:  osmo-iuh_1.3.0.202208020002.tar.xz
25
BuildRequires:  automake >= 1.9
26
BuildRequires:  libtool >= 2
27
BuildRequires:  lksctp-tools-devel
28
BuildRequires:  pkgconfig >= 0.20
29
# python3 for asn1tostruct.py
30
BuildRequires:  python3
31
BuildRequires:  pkgconfig(libasn1c) >= 0.9.30
32
BuildRequires:  pkgconfig(libosmo-netif) >= 1.2.0
33
BuildRequires:  pkgconfig(libosmo-sigtran) >= 1.6.0
34
BuildRequires:  pkgconfig(libosmocore) >= 1.7.0
35
BuildRequires:  pkgconfig(libosmoctrl) >= 1.7.0
36
BuildRequires:  pkgconfig(libosmogb) >= 1.7.0
37
BuildRequires:  pkgconfig(libosmogsm) >= 1.7.0
38
BuildRequires:  pkgconfig(libosmovty) >= 1.7.0
39
40
%description
41
Osmocom code for the Iuh interface (HNBAP, RUA, RANAP)
42
43
%package -n libosmo-hnbap0
44
Requires: osmocom-nightly = 1.0.0.202208020002
45
Summary:        Shared Library part of libosmo-hnbap
46
Group:          System/Libraries
47
48
%description -n libosmo-hnbap0
49
Osmocom code for the Iuh interface (HNBAP, RUA, RANAP)
50
51
%package -n libosmo-hnbap-devel
52
Requires: osmocom-nightly = 1.0.0.202208020002
53
Summary:        Development files for Osmocom HNBAP library
54
Group:          Development/Libraries/C and C++
55
Requires:       libosmo-hnbap0 = %{version}
56
57
%description -n libosmo-hnbap-devel
58
Osmocom code for the Iuh interface (HNBAP, RUA, RANAP)
59
60
%package -n libosmo-ranap5
61
Requires: osmocom-nightly = 1.0.0.202208020002
62
Summary:        Shared Library part of libosmo-ranap
63
Group:          System/Libraries
64
65
%description -n libosmo-ranap5
66
Osmocom code for the Iuh interface (HNBAP, RUA, RANAP)
67
68
%package -n libosmo-ranap-devel
69
Requires: osmocom-nightly = 1.0.0.202208020002
70
Summary:        Development files for Osmocom RANAP library
71
Group:          Development/Libraries/C and C++
72
Requires:       libosmo-ranap5 = %{version}
73
74
%description -n libosmo-ranap-devel
75
Osmocom code for the Iuh interface (HNBAP, RUA, RANAP)
76
77
This subpackage contains libraries and header files for developing
78
applications that want to make use of libosmoranap.
79
80
%package -n libosmo-rua0
81
Requires: osmocom-nightly = 1.0.0.202208020002
82
Summary:        Shared Library part of libosmo-rua
83
Group:          System/Libraries
84
85
%description -n libosmo-rua0
86
Osmocom code for the Iuh interface (HNBAP, RUA, RANAP)
87
88
%package -n libosmo-rua-devel
89
Requires: osmocom-nightly = 1.0.0.202208020002
90
Summary:        Development files for Osmocom RUA library
91
Group:          Development/Libraries/C and C++
92
Requires:       libosmo-rua0 = %{version}
93
94
%description -n libosmo-rua-devel
95
Osmocom code for the Iuh interface (HNBAP, RUA, RANAP)
96
97
%package -n libosmo-sabp1
98
Requires: osmocom-nightly = 1.0.0.202208020002
99
Summary:        Shared Library part of libosmo-sabp
100
Group:          System/Libraries
101
102
%description -n libosmo-sabp1
103
Osmocom code for the SABP (service area broadcast protocol) interface
104
105
%package -n libosmo-sabp-devel
106
Requires: osmocom-nightly = 1.0.0.202208020002
107
Summary:        Development files for Osmocom SABP library
108
Group:          Development/Libraries/C and C++
109
Requires:       libosmo-sabp1 = %{version}
110
111
%description -n libosmo-sabp-devel
112
Osmocom code for the SABP (service area broadcast protocol) interface
113
114
This subpackage contains libraries and header files for developing
115
applications that want to make use of libosmo-sabp.
116
117
118
%prep
119
%setup -q
120
121
%build
122
# HACK: don't let rpmlint abort the build when it finds that a library depends
123
# on a package with a specific version. The path used here is listed in:
124
# https://build.opensuse.org/package/view_file/devel:openSUSE:Factory:rpmlint/rpmlint-mini/rpmlint-mini.config?expand=1
125
# Instead of writing to the SOURCES dir, we could upload osmocom-rpmlintrc as
126
# additional source for each package. But that's way more effort, not worth it.
127
echo "setBadness('shlib-fixed-dependency', 0)" \
128
    > "%{_sourcedir}/osmocom-rpmlintrc"
129
130
echo "%{version}" >.tarball-version
131
autoreconf -fi
132
%configure \
133
  --disable-static \
134
  --docdir="%{_docdir}/%{name}"
135
make %{?_smp_mflags}
136
137
%install
138
%make_install
139
find %{buildroot} -type f -name "*.la" -delete -print
140
141
%check
142
make %{?_smp_mflags} check || (find . -name testsuite.log -exec cat {} +)
143
144
%post   -n libosmo-hnbap0 -p /sbin/ldconfig
145
%postun -n libosmo-hnbap0 -p /sbin/ldconfig
146
%post   -n libosmo-ranap5 -p /sbin/ldconfig
147
%postun -n libosmo-ranap5 -p /sbin/ldconfig
148
%post   -n libosmo-rua0 -p /sbin/ldconfig
149
%postun -n libosmo-rua0 -p /sbin/ldconfig
150
%post   -n libosmo-sabp1 -p /sbin/ldconfig
151
%postun -n libosmo-sabp1 -p /sbin/ldconfig
152
153
%files
154
%license COPYING
155
%doc README.md
156
157
%files -n libosmo-hnbap0
158
%{_libdir}/libosmo-hnbap.so.0*
159
160
%files -n libosmo-hnbap-devel
161
%dir %{_includedir}/osmocom/
162
%dir %{_includedir}/osmocom/hnbap/
163
%{_includedir}/osmocom/hnbap/*
164
%{_libdir}/libosmo-hnbap.so
165
%{_libdir}/pkgconfig/libosmo-hnbap.pc
166
167
%files -n libosmo-ranap5
168
%{_libdir}/libosmo-ranap.so.5*
169
170
%files -n libosmo-ranap-devel
171
%dir %{_includedir}/osmocom/
172
%dir %{_includedir}/osmocom/ranap/
173
%{_includedir}/osmocom/ranap/*
174
%{_libdir}/libosmo-ranap.so
175
%{_libdir}/pkgconfig/libosmo-ranap.pc
176
177
%files -n libosmo-rua0
178
%{_libdir}/libosmo-rua.so.0*
179
180
%files -n libosmo-rua-devel
181
%dir %{_includedir}/osmocom/
182
%dir %{_includedir}/osmocom/rua/
183
%{_includedir}/osmocom/rua/*
184
%{_libdir}/libosmo-rua.so
185
%{_libdir}/pkgconfig/libosmo-rua.pc
186
187
%files -n libosmo-sabp1
188
%{_libdir}/libosmo-sabp.so.1*
189
190
%files -n libosmo-sabp-devel
191
%dir %{_includedir}/osmocom/
192
%dir %{_includedir}/osmocom/sabp/
193
%{_includedir}/osmocom/sabp/*
194
%{_libdir}/libosmo-sabp.so
195
%{_libdir}/pkgconfig/libosmo-sabp.pc
196
197
%changelog
198