File osmo-iuh.spec of Package osmo-iuh (Revision 472)
Currently displaying revision 472 , Show latest
191
1
#
2
# spec file for package osmo-iuh
3
#
4
# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
5
# Copyright (c) 2021 sysmocom - s.f.m.c GmbH
6
#
7
# All modifications and additions to the file contributed by third parties
8
# remain the property of their copyright owners, unless otherwise agreed
9
# upon. The license for this file, and modifications and additions to the
10
# file, is the same license as for the pristine package itself (unless the
11
# license for the pristine package is not an Open Source License, in which
12
# case the license is the MIT License). An "Open Source License" is a
13
# license that conforms to the Open Source Definition (Version 1.9)
14
# published by the Open Source Initiative.
15
16
Name: osmo-iuh
17
Requires: osmocom-nightly = 202310032026
18
Version: 1.5.0.202310032026
19
Release: 0
20
Summary: Osmocom code for the Iuh interface (HNBAP, RUA, RANAP)
21
License: AGPL-3.0-or-later AND GPL-2.0-or-later
22
Group: Hardware/Mobile
23
URL: https://osmocom.org/projects/osmohnbgw
24
Source: osmo-iuh_1.5.0.202310032026.tar.xz
25
Source1: rpmlintrc
26
BuildRequires: automake >= 1.9
27
BuildRequires: libtool >= 2
28
BuildRequires: lksctp-tools-devel
29
BuildRequires: pkgconfig >= 0.20
30
# python3 for asn1tostruct.py
31
BuildRequires: python3
32
BuildRequires: pkgconfig(libasn1c) >= 0.9.30
33
BuildRequires: pkgconfig(libosmocore) >= 1.9.0
34
BuildRequires: pkgconfig(libosmoctrl) >= 1.9.0
35
BuildRequires: pkgconfig(libosmogb) >= 1.9.0
36
BuildRequires: pkgconfig(libosmogsm) >= 1.9.0
37
BuildRequires: pkgconfig(libosmovty) >= 1.9.0
38
BuildRequires: pkgconfig(libosmo-netif) >= 1.4.0
39
BuildRequires: pkgconfig(libosmo-sigtran) >= 1.8.0
40
41
%description
42
Osmocom code for the Iuh interface (HNBAP, RUA, RANAP)
43
44
%package -n libosmo-hnbap0
45
Requires: osmocom-nightly = 202310032026
46
Summary: Shared Library part of libosmo-hnbap
47
Group: System/Libraries
48
49
%description -n libosmo-hnbap0
50
Osmocom code for the Iuh interface (HNBAP, RUA, RANAP)
51
52
%package -n libosmo-hnbap-devel
53
Requires: osmocom-nightly = 202310032026
54
Summary: Development files for Osmocom HNBAP library
55
Group: Development/Libraries/C and C++
56
Requires: libosmo-hnbap0 = %{version}
57
58
%description -n libosmo-hnbap-devel
59
Osmocom code for the Iuh interface (HNBAP, RUA, RANAP)
60
61
%package -n libosmo-ranap7
62
Requires: osmocom-nightly = 202310032026
63
Summary: Shared Library part of libosmo-ranap
64
Group: System/Libraries
65
66
%description -n libosmo-ranap7
67
Osmocom code for the Iuh interface (HNBAP, RUA, RANAP)
68
69
%package -n libosmo-ranap-devel
70
Requires: osmocom-nightly = 202310032026
71
Summary: Development files for Osmocom RANAP library
72
Group: Development/Libraries/C and C++
73
Requires: libosmo-ranap7 = %{version}
74
75
%description -n libosmo-ranap-devel
76
Osmocom code for the Iuh interface (HNBAP, RUA, RANAP)
77
78
This subpackage contains libraries and header files for developing
79
applications that want to make use of libosmoranap.
80
81
%package -n libosmo-rua0
82
Requires: osmocom-nightly = 202310032026
83
Summary: Shared Library part of libosmo-rua
84
Group: System/Libraries
85
86
%description -n libosmo-rua0
87
Osmocom code for the Iuh interface (HNBAP, RUA, RANAP)
88
89
%package -n libosmo-rua-devel
90
Requires: osmocom-nightly = 202310032026
91
Summary: Development files for Osmocom RUA library
92
Group: Development/Libraries/C and C++
93
Requires: libosmo-rua0 = %{version}
94
95
%description -n libosmo-rua-devel
96
Osmocom code for the Iuh interface (HNBAP, RUA, RANAP)
97
98
%package -n libosmo-sabp1
99
Requires: osmocom-nightly = 202310032026
100
Summary: Shared Library part of libosmo-sabp
101
Group: System/Libraries
102
103
%description -n libosmo-sabp1
104
Osmocom code for the SABP (service area broadcast protocol) interface
105
106
%package -n libosmo-sabp-devel
107
Requires: osmocom-nightly = 202310032026
108
Summary: Development files for Osmocom SABP library
109
Group: Development/Libraries/C and C++
110
Requires: libosmo-sabp1 = %{version}
111
112
%description -n libosmo-sabp-devel
113
Osmocom code for the SABP (service area broadcast protocol) interface
114
115
This subpackage contains libraries and header files for developing
116
applications that want to make use of libosmo-sabp.
117
118
119
%prep
120
%setup -n osmo-iuh -q
121
122
%build
123
echo "%{version}" >.tarball-version
124
autoreconf -fi
125
%configure \
126
--disable-static \
127
--docdir="%{_docdir}/%{name}"
128
make %{?_smp_mflags}
129
130
%install
131
%make_install
132
find %{buildroot} -type f -name "*.la" -delete -print
133
134
%check
135
make %{?_smp_mflags} check || (find . -name testsuite.log -exec cat {} +)
136
137
%post -n libosmo-hnbap0 -p /sbin/ldconfig
138
%postun -n libosmo-hnbap0 -p /sbin/ldconfig
139
%post -n libosmo-ranap7 -p /sbin/ldconfig
140
%postun -n libosmo-ranap7 -p /sbin/ldconfig
141
%post -n libosmo-rua0 -p /sbin/ldconfig
142
%postun -n libosmo-rua0 -p /sbin/ldconfig
143
%post -n libosmo-sabp1 -p /sbin/ldconfig
144
%postun -n libosmo-sabp1 -p /sbin/ldconfig
145
146
%files
147
%license COPYING
148
%doc README.md
149
150
%files -n libosmo-hnbap0
151
%{_libdir}/libosmo-hnbap.so.0*
152
153
%files -n libosmo-hnbap-devel
154
%dir %{_includedir}/osmocom/
155
%dir %{_includedir}/osmocom/hnbap/
156
%{_includedir}/osmocom/hnbap/*
157
%{_libdir}/libosmo-hnbap.so
158
%{_libdir}/pkgconfig/libosmo-hnbap.pc
159
160
%files -n libosmo-ranap7
161
%{_libdir}/libosmo-ranap.so.7*
162
163
%files -n libosmo-ranap-devel
164
%dir %{_includedir}/osmocom/
165
%dir %{_includedir}/osmocom/ranap/
166
%{_includedir}/osmocom/ranap/*
167
%{_libdir}/libosmo-ranap.so
168
%{_libdir}/pkgconfig/libosmo-ranap.pc
169
170
%files -n libosmo-rua0
171
%{_libdir}/libosmo-rua.so.0*
172
173
%files -n libosmo-rua-devel
174
%dir %{_includedir}/osmocom/
175
%dir %{_includedir}/osmocom/rua/
176
%{_includedir}/osmocom/rua/*
177
%{_libdir}/libosmo-rua.so
178
%{_libdir}/pkgconfig/libosmo-rua.pc
179
180
%files -n libosmo-sabp1
181
%{_libdir}/libosmo-sabp.so.1*
182
183
%files -n libosmo-sabp-devel
184
%dir %{_includedir}/osmocom/
185
%dir %{_includedir}/osmocom/sabp/
186
%{_includedir}/osmocom/sabp/*
187
%{_libdir}/libosmo-sabp.so
188
%{_libdir}/pkgconfig/libosmo-sabp.pc
189
190
%changelog
191