File osmo-msc.spec of Package osmo-msc (Revision 12090a23ffd5a2c54ae54c2ed2329aca)
Currently displaying revision 12090a23ffd5a2c54ae54c2ed2329aca , Show latest
121
1
#
2
# spec file for package osmo-msc
3
#
4
# Copyright (c) 2017, Martin Hauke <mardnh@gmx.de>
5
#
6
# All modifications and additions to the file contributed by third parties
7
# remain the property of their copyright owners, unless otherwise agreed
8
# upon. The license for this file, and modifications and additions to the
9
# file, is the same license as for the pristine package itself (unless the
10
# license for the pristine package is not an Open Source License, in which
11
# case the license is the MIT License). An "Open Source License" is a
12
# license that conforms to the Open Source Definition (Version 1.9)
13
# published by the Open Source Initiative.
14
15
## Disable LTO for now since it breaks compilation of the tests
16
## https://osmocom.org/issues/4115
17
%define _lto_cflags %{nil}
18
19
%define with_iu 1
20
Name: osmo-msc
21
Requires: osmocom-nightly = 202306040026
22
Version: 1.10.0.54.d3ab.202306040026
23
Release: 0
24
Summary: Osmocom's MSC for 2G and 3G circuit-switched mobile networks
25
License: AGPL-3.0-or-later AND GPL-2.0-only
26
Group: Productivity/Telephony/Servers
27
URL: https://osmocom.org/projects/osmomsc
28
Source: osmo-msc_1.10.0.54.d3ab.202306040026.tar.xz
29
Source1: rpmlintrc
30
BuildRequires: autoconf
31
BuildRequires: automake
32
BuildRequires: libtool
33
%if 0%{?suse_version}
34
BuildRequires: systemd-rpm-macros
35
%endif
36
BuildRequires: pkgconfig >= 0.20
37
BuildRequires: pkgconfig(sqlite3)
38
BuildRequires: pkgconfig(libcrypto) >= 0.9.5
39
BuildRequires: pkgconfig(libosmo-gsup-client) >= 1.6.0
40
BuildRequires: pkgconfig(libosmo-mgcp-client) >= 1.11.0
41
BuildRequires: pkgconfig(libosmo-netif) >= 1.3.0
42
BuildRequires: pkgconfig(libosmo-sccp) >= 1.7.0
43
BuildRequires: pkgconfig(libosmo-sigtran) >= 1.7.0
44
BuildRequires: pkgconfig(libosmoabis) >= 1.4.0
45
BuildRequires: pkgconfig(libosmocore) >= 1.8.0
46
BuildRequires: pkgconfig(libosmoctrl) >= 1.8.0
47
BuildRequires: pkgconfig(libosmogsm) >= 1.8.0
48
BuildRequires: pkgconfig(libosmovty) >= 1.8.0
49
BuildRequires: pkgconfig(libsmpp34) >= 1.14.0
50
####
51
BuildRequires: lksctp-tools-devel
52
####
53
%{?systemd_requires}
54
%if %{with_iu}
55
BuildRequires: pkgconfig(libasn1c) >= 0.9.30
56
BuildRequires: pkgconfig(libosmo-ranap) >= 1.4.0
57
%endif
58
59
%description
60
The Mobile Switching Center (MSC) is the heart of 2G/3G
61
circuit-switched services. It terminates the A-interface links from the
62
Base Station Controllers (BSC) and handles the MM and CC sub-layers of
63
the Layer 3 protocol from the phones (MS).
64
65
This Osmocom implementation of the MSC handles A interfaces via 3GPP
66
AoIP in an ASP role. It furthermore implements IETF MGCP against an
67
external media gateway, such as OsmoMGW. It does *not* implement MAP
68
towards a HLR, but the much simpler Osmocom GSUP protocol, which can
69
be translated to MAP if needed.
70
71
%prep
72
%setup -n osmo-msc -q
73
74
%build
75
echo "%{version}" >.tarball-version
76
autoreconf -fi
77
%configure \
78
%if %{with_iu}
79
--enable-iu \
80
%endif
81
--enable-smpp \
82
--docdir=%{_docdir}/%{name} \
83
--with-systemdsystemunitdir=%{_unitdir}
84
85
make %{?_smp_mflags}
86
87
%install
88
%make_install
89
90
%if 0%{?suse_version}
91
%preun
92
%service_del_preun %{name}.service
93
94
%postun
95
%service_del_postun %{name}.service
96
97
%pre
98
%service_add_pre %{name}.service
99
100
%post
101
%service_add_post %{name}.service
102
%endif
103
104
%check
105
make %{?_smp_mflags} check || (find . -name testsuite.log -exec cat {} +)
106
107
%files
108
%license COPYING
109
%doc AUTHORS README.md
110
%dir %{_docdir}/%{name}/examples
111
%dir %{_docdir}/%{name}/examples/osmo-msc
112
%{_docdir}/%{name}/examples/osmo-msc/osmo-msc.cfg
113
%{_docdir}/%{name}/examples/osmo-msc/osmo-msc_custom-sccp.cfg
114
%{_docdir}/%{name}/examples/osmo-msc/osmo-msc_multi-cs7.cfg
115
%{_bindir}/osmo-msc
116
%{_unitdir}/%{name}.service
117
%dir %{_sysconfdir}/osmocom
118
%config(noreplace) %{_sysconfdir}/osmocom/osmo-msc.cfg
119
120
%changelog
121