File osmo-msc.spec of Package osmo-msc (Revision f54b2708d380fd2820be3a9c06687912)
Currently displaying revision f54b2708d380fd2820be3a9c06687912 , Show latest
128
1
#
2
# spec file for package osmo-msc
3
#
4
# Copyright (c) 2017, Martin Hauke <mardnh@gmx.de>
5
#
6
# All modifications and additions to the file contributed by third parties
7
# remain the property of their copyright owners, unless otherwise agreed
8
# upon. The license for this file, and modifications and additions to the
9
# file, is the same license as for the pristine package itself (unless the
10
# license for the pristine package is not an Open Source License, in which
11
# case the license is the MIT License). An "Open Source License" is a
12
# license that conforms to the Open Source Definition (Version 1.9)
13
# published by the Open Source Initiative.
14
15
## Disable LTO for now since it breaks compilation of the tests
16
## https://osmocom.org/issues/4115
17
%define _lto_cflags %{nil}
18
19
%define with_iu 1
20
Name: osmo-msc
21
Requires: osmocom-nightly = 1.0.0.202207170002
22
Version: 1.9.0.2.99bd.202207170002
23
Release: 0
24
Summary: Osmocom's MSC for 2G and 3G circuit-switched mobile networks
25
License: AGPL-3.0-or-later AND GPL-2.0-only
26
Group: Productivity/Telephony/Servers
27
URL: https://osmocom.org/projects/osmomsc
28
Source: osmo-msc_1.9.0.2.99bd.202207170002.tar.xz
29
BuildRequires: autoconf
30
BuildRequires: automake
31
BuildRequires: libtool
32
%if 0%{?suse_version}
33
BuildRequires: systemd-rpm-macros
34
%endif
35
BuildRequires: pkgconfig >= 0.20
36
BuildRequires: pkgconfig(sqlite3)
37
BuildRequires: pkgconfig(libcrypto) >= 0.9.5
38
BuildRequires: pkgconfig(libosmo-gsup-client) >= 1.5.0
39
BuildRequires: pkgconfig(libosmo-mgcp-client) >= 1.10.0
40
BuildRequires: pkgconfig(libosmo-netif) >= 1.2.0
41
BuildRequires: pkgconfig(libosmo-sccp) >= 1.6.0
42
BuildRequires: pkgconfig(libosmo-sigtran) >= 1.6.0
43
BuildRequires: pkgconfig(libosmoabis) >= 1.3.0
44
BuildRequires: pkgconfig(libosmocore) >= 1.7.0
45
BuildRequires: pkgconfig(libosmoctrl) >= 1.7.0
46
BuildRequires: pkgconfig(libosmogsm) >= 1.7.0
47
BuildRequires: pkgconfig(libosmovty) >= 1.7.0
48
BuildRequires: pkgconfig(libsmpp34) >= 1.14.0
49
####
50
BuildRequires: lksctp-tools-devel
51
####
52
%{?systemd_requires}
53
%if %{with_iu}
54
BuildRequires: pkgconfig(libasn1c) >= 0.9.30
55
BuildRequires: pkgconfig(libosmo-ranap) >= 1.3.0
56
%endif
57
58
%description
59
The Mobile Switching Center (MSC) is the heart of 2G/3G
60
circuit-switched services. It terminates the A-interface links from the
61
Base Station Controllers (BSC) and handles the MM and CC sub-layers of
62
the Layer 3 protocol from the phones (MS).
63
64
This Osmocom implementation of the MSC handles A interfaces via 3GPP
65
AoIP in an ASP role. It furthermore implements IETF MGCP against an
66
external media gateway, such as OsmoMGW. It does *not* implement MAP
67
towards a HLR, but the much simpler Osmocom GSUP protocol, which can
68
be translated to MAP if needed.
69
70
%prep
71
%setup -q
72
73
%build
74
# HACK: don't let rpmlint abort the build when it finds that a library depends
75
# on a package with a specific version. The path used here is listed in:
76
# https://build.opensuse.org/package/view_file/devel:openSUSE:Factory:rpmlint/rpmlint-mini/rpmlint-mini.config?expand=1
77
# Instead of writing to the SOURCES dir, we could upload osmocom-rpmlintrc as
78
# additional source for each package. But that's way more effort, not worth it.
79
echo "setBadness('shlib-fixed-dependency', 0)" \
80
> "%{_sourcedir}/osmocom-rpmlintrc"
81
82
echo "%{version}" >.tarball-version
83
autoreconf -fi
84
%configure \
85
%if %{with_iu}
86
--enable-iu \
87
%endif
88
--enable-smpp \
89
--docdir=%{_docdir}/%{name} \
90
--with-systemdsystemunitdir=%{_unitdir}
91
92
make %{?_smp_mflags}
93
94
%install
95
%make_install
96
97
%if 0%{?suse_version}
98
%preun
99
%service_del_preun %{name}.service
100
101
%postun
102
%service_del_postun %{name}.service
103
104
%pre
105
%service_add_pre %{name}.service
106
107
%post
108
%service_add_post %{name}.service
109
%endif
110
111
%check
112
make %{?_smp_mflags} check || (find . -name testsuite.log -exec cat {} +)
113
114
%files
115
%license COPYING
116
%doc AUTHORS README.md
117
%dir %{_docdir}/%{name}/examples
118
%dir %{_docdir}/%{name}/examples/osmo-msc
119
%{_docdir}/%{name}/examples/osmo-msc/osmo-msc.cfg
120
%{_docdir}/%{name}/examples/osmo-msc/osmo-msc_custom-sccp.cfg
121
%{_docdir}/%{name}/examples/osmo-msc/osmo-msc_multi-cs7.cfg
122
%{_bindir}/osmo-msc
123
%{_unitdir}/%{name}.service
124
%dir %{_sysconfdir}/osmocom
125
%config(noreplace) %{_sysconfdir}/osmocom/osmo-msc.cfg
126
127
%changelog
128